Back to overview
Maintenance
Updating Production
May 1, 2026 at 2:10am UTC
–
May 1, 2026 at 4:10am UTC
Affected services
My Chappie Backend
My Chappie Frontend
Resolved
May 1, 2026 at 4:10am UTC
Maintenance ended
Affected services
Created
May 1, 2026 at 2:10am UTC
Updating Production
Affected services